New Cougar Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
540 Posts
Yep, Mine does the same thing. Aside from epoxying it in I have found no solution but to snap it back down every couple days. Oh yeah it really annoys me too.:mad:
 

·
Registered
Joined
·
4,201 Posts
Mine does the same. I'm about to do the same thing scottina did.
 
G

·
Discussion Starter · #8 ·
Has anyone actually read what Ford has had to say about this problem? Alldata says that there is a Service Bulletin on the Mercury Cougar, "#01-22-4 NOV 01 Dashboard - Defroster Grille Lifting Out of Position." I'd love to be able to read it, but Alldata makes you pay in order to do so.
 

·
Registered
Joined
·
5,817 Posts
Yea, there is a TSB about it...which was designed to save Ford money. There was a recall for the Contour/Mystique for dash seperation, where the dash was lifting away from the windshield. The original recall was to replace the entire dash, then was revised to just include a cover to hide the problem.

Well, some techs were trying to order complete dashes for Cougars because of the vent popping out. Ford then issued a TSB for this problem, for techs to order a $50 "kit" to fix the problem.

What is this $50 "kit" you may ask.....well. It is a bag of velcro squares. Yup, five velcro squares, 1"x1"......for $50. I kid you not. The tech slapps the five squares in place, to hold the vent down.

Go get a bottle of super glue, and fix the problem that way. It is a simple fix, takes a few seconds. If you remove the vent and look at the bottom of it, you can see where it was originally glued in place. Just put a few dabs of super glue on each tab, have someone hold the other side of the vent, and both of you hold it in place from outside the car, reaching in through the open windows. Mine has been sitting perfectly in place ever since. :)
 
G

·
Discussion Starter · #11 ·
I couldn't bring myself to super-gluing my baby, so I went to Staples and purchased a "kit" for $3 :biggrin:



I bought the black ones though to match the black interior, not the white (as if it matters). Works like a charm! :)
 

·
Registered
Joined
·
11 Posts
aren't there supposed to be clips that hold it in I just had to get my blower motor rplaced about 3 months ago, and had never had problem till then now it won't stay down and it looks like they melted a bunch of something off of it. at about 2 inch intervals along the whole thing mmust have pissed mechanic off or something . unless ford makes thier defrost covers with chunks of melted plastic all over them
 
1 - 12 of 12 Posts
Top