New Cougar Forum banner
1 - 8 of 8 Posts

·
Banned
Joined
·
5,851 Posts
Discussion Starter · #1 ·
when i start my car and rev the engine, it make this annoying ass whining noise and it won't go away. it started about a week and a half ago when my a/c stopped working, since then i put on a new a/c compressor and recharged it, but i have no clue what so ever on what the hell this whinning noise is! i think maybe the water pump, but i have no clue! anyone got some ideas?
:confused::mad::thumbsdn:
 

·
Administrator
1999 3.0 SilFro
Joined
·
25,008 Posts
Water pump noise will come from your battery area.

Perhaps you need a new belt.
 

·
Banned
Joined
·
5,851 Posts
Discussion Starter · #7 ·
would that noise maybe be the power steering pump? cause it made that noise on my other 99 cougar i had and the power steering pump was the problem!
 

·
Banned
Joined
·
5,184 Posts
There is a pretty good chance of the being the problem. If that is the case nullxposure has one for sale cheap, check it out. Sometime if you take the cap off the noise will increase. Try that start it up, and leave engine at idle, remove the cap have someone slowly turn the wheel from lock to lock when reaching full lock put a slight bit of extra preasure on it. Not for long though if your pump is in fact good holding the wheel like that very long will indeed make the pump not good. But a few seconds isn't gonna hurt anything.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top