New Cougar Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I Have a 1999 Mecury Cougar V6 2.5L DOHC Automatic, here are some of my problems: I replaced my battery with a new Duralast Gold battery, but my car still won't start... it's not turning over or anything. Some have told me it could be the alernator it has already been replaced twice, but I know this a common Cougar problem!!! I noticed that my Cougar has a huge oil leak problem the alternator is completely saturated in oil possibly shorting out the alternator and affecting the serpentine belt on the tensioner..... those are just a few of the problems...... Please help Cougar Owners!!!!

D.C. :banghead:
 

·
Registered
Joined
·
2,307 Posts
what does the car do when you crank it over? does it turn over? do you hear any noises? do you hear a clicking sound?

yes the oil leak on the alternator isn't good but it shouldn't prevent the car from starting.

also does the engine turn freely? take the accessory belt off and try starting it once you have confirmed the starter is good.

also what is the pats light doing when you try to start the car?
 

·
Administrator
Joined
·
24,405 Posts
You probably need a new starter.

Even a car with no alternator at all will start with a new battery installed, if everything else is working correctly.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
It does make a clicking sound on me... it eventually starts up, but turns right back off on me. What do you think coud be causing this?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
I'm going to go ahead and save up for a new starter and see if it works out for me, but when the car turns over it makes a rapid clicking noise, it starts up when I get a boost, but as soon as I diconnect the cables the car shuts off. Any suggestions for me?
 

·
Registered
Joined
·
392 Posts
guys, there is a seal in one of those pulley wheels or belt wheels (whatever its called) if im not mistaken, and please correct me if im wrong. my seal was bad, and we had to replace it. it was allowing oil to leak out on the belt which in turn was slinging it into the unsuspecting alternator, which eventually over time, ruined it. just so the individual knows that that is a possibility of where his oil leak is coming from...
 

·
Registered
Joined
·
2,307 Posts
I'm going to go ahead and save up for a new starter and see if it works out for me, but when the car turns over it makes a rapid clicking noise, it starts up when I get a boost, but as soon as I diconnect the cables the car shuts off. Any suggestions for me?

sounds like a bad connection somewhere. also if it starts then there is a chance the starter is ok.
 

·
Registered
Joined
·
706 Posts
check the voltage of your batt. with the car off and with it running. should be about 12v and 14+v. the the engine turns over with out grinding like hell the starter is fine... if it only clicks look for bad connections
 
1 - 8 of 8 Posts
Top