New Cougar Forum banner
1 - 17 of 17 Posts

·
Premium Member
Joined
·
7,864 Posts
Discussion Starter · #1 ·
Just wanted to spread the info. I've been fighting a surging problem with the 3L SVT Contour I built for my wife a year ago. It hasn't been a major issue so I haven't had to fix it right away. The surging basically happens only when the car is crusing. Nothing horrible but you can feel it and it gets annoying. It ran fine at idle and wide open throttle (WOT). I talked to a friend recently and he said his DPFE sensor was causing the problem with his lightning. He said if you unplug the sensor the surging should go away if that is the problem. If that fixes then you have to buy a new DPFE sensor and replace the bad one. I found out that the DPFE sensor is NOT monitoring the EGR gases at idle or WOT so now it makes perfect sense. It is only working when cursing or at half throttle. I tried unplugging the sensor and after a few minutes the surging went away. For anyone having this exact issue: "Surging only at crusing speeds" I recommend unplugging the DPFE sensor to see if this fixes it. If that's the cause look for a new one. Hope this helps someone.

Chris
 
G

·
Im wondering if thats the problem with my 3L 99 Taurus. Im having a surging at light throttle cruising speeds, almost feels like the tranny is slipping but that was replaced under warranty 20k miles ago.
 

·
Registered
Joined
·
2 Posts
My 1999 cougar is having the same problem.
Can someone tell me where this DPFE sensor is? I don't have a service manual yet.
I've had this car to the dealer for this issue and they said "normal performance" after diagnostics were done and Paid for Too!

:crazy:
 

·
Registered
Joined
·
3,206 Posts
Yes! That is the part exactly!
 

·
Registered
Joined
·
27 Posts
god i hope this fixes the problem, i have played the replace parts game for over 3 months now, replaced fuel flter, fuel pump, wire, plugs, irmc, iacv, tps sensor, pcv, cleaned upper and lower intake. the only time i dont have the surging problem is when i run a full bottle of redline complete fuel system cleaner twice now i have put that in my tank and the surging went away, sat i filled up after running to to about 1/4 tank and the surging was back this morning. i wonder why it would run ok with fuel system cleaner and surge again after the is burnt out of the tank.
 

·
Registered
Joined
·
3,696 Posts
Wait.. that link is for a EGR valve... not for a DPFE...

I get VERY slight surges sometimes... so i should try the DPFE or the EGR?
 

·
Registered
Joined
·
3,206 Posts
No its not the EGR!! That link is for the DPFE or EGR position switch (same thing, different name) I know it is b/c i got mine from there and just look at the part man!
 

·
Registered
Joined
·
27 Posts
the dpfe didnt fix the problem, changed out the dpfe last night, i will see i have a quicker response at the throttle, but i still have the surging problem..

i dont know what else to do, no cel lights. nothing else noticable either.
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top