New Cougar Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
171 Posts
The PE module simply wires into the factory harness of the IAT sensor
Lol... It looks like the cheap thing that make your IAT think the air taken from filter is very very cold. Can someone confirm?:evil:
 

·
Registered
Joined
·
66 Posts
thats what it looks like to me too. i used one of the ones from ebay when running a autoX one day.....not serious just a local event......i forgot to take it out and ran rich way too long. not only did it affect fuel mileage, but i have 2 clogged precats now, which i have to gut. i would stay away from any of that "easy install" stuff. if its that easy, probably nothin but trouble.
 

·
Registered
Joined
·
1,393 Posts
Discussion Starter · #4 ·
well i appreciate the input guys i've seen a bunch talk about the xcal but havent been able to locate that. anyone know where i can find one?
 

·
Registered
Joined
·
78 Posts
I've used the Surge Performance Chip. I did feel a little power only at night time. But it's tricking your ECU thinking your computer is running cold and needs more fuel. I couldn't pass smog and the CEL would come on non stop. It was connected to the IAT Sensor. It's a COMPLETE WASTE OF MONEY...It caused more problems. I just found it it's the same Resistor(So-Called Performance Chip) is actually a LED/Neon Tube Light Adjuster Here's the Link To Prove It...Just Scroll Down You'll Know Why.

Performance Chip Tuning Racing ECU Car Chips Power Super Flash
 
1 - 7 of 7 Posts
Top