New Cougar Forum banner

1 - 20 of 34 Posts

·
Registered
Joined
·
2,470 Posts
Discussion Starter #1 (Edited)
Well, after waiting patiently for three weeks, my Centerline Vantage 19s arrived this morning (after being custom built for me)! :)

These pics are just the "chops", but I'll post the REAL THING shortly! (looks EVEN BETTER in "real life"!)

Just thought I'd share my excitement w/ everyone! Hehe! ;)








~CIII
 

·
Registered
Joined
·
1,258 Posts
tight, the second pic ur ride reminded me of a real mustang!:thumbsup:
 

·
Registered
Joined
·
4,470 Posts
right.
so...that's a photochop
do you have any Actual pics of the rims on the car?
BTW awesome choice of rims!:thumbsup:
 

·
Registered
Joined
·
2,470 Posts
Discussion Starter #11
Sorry, I just had them installed yesterday afternoon (ditched work to get them put on ;))...I'm going to borrow my neighbor's digi-cam in the next day or two and get some REAL pics to post for everyone (BTW...The wheels don't look HUGE on the car like in the "chops"...Those photoshops make the large size seem exaggerated).

I'll try to get the pics up soon!

~CIII
 

·
Registered
Joined
·
2,470 Posts
Discussion Starter #18
Viz...You are ALWAYS funny as hell! Hahaha! :rofl:

I'll borrow the digi-cam tomorrow (if I have time) to post REAL pics of the wheels...Sorry to disappoint you Chris, but they REALLY don't rub...I promise! ;) That was the FIRST thing I checked after the install...I drove in tight circles around the parking lot and then took a few speed bumps and faster turns...no rubbing anywhere! They've been on the car for two full days now and no sign of rubbing during any maneuvers! I've been checking both the inside and outside of the tires and nothing rubs!

Sorry to keep everyone waiting for pics!

~CIII
 
1 - 20 of 34 Posts
Top