New Cougar Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
510 Posts
Discussion Starter · #1 ·
Well my cougar is in bad bad shape thanks to this crap load of rain we got

i was working and got off work at 10pm when it was raining hard and fast

was driving down 61, i was like the only car on the road and i couldnt figure out why

well i got near 70th street bridge when i nailed a huge ass puddle of water going about 50 (for once i was driving normal :p)
and i swear the water had to be a foot to two feet high, almost staled my car but it went trough, lights were dim and car was alittle slugish
but it kept going and started working fine

well as i got up to 494 i nailed yet again another huge ass puddle of water this this time i was going like 40 lol, but this time the water not [censored]ting you
was up to my window, i freaked and then all of a sudden my car died. Here i am traped in water up to my window lol, luckly a state trooper seen me stuck and came over
and pulled me out of my window. but the bad thing is when i rolled down my window all the damn water went in my car :ugh: the only thing that kept coming to my mind
is my leather sets in my car :( hopefully they arnt that messed up but i got a feeling they will be.

But ya i called a towe truck company and they were so busy it and it was the only one that i could find that could get my car the fastest, but they said they would towe my car around 2am ish and bring it to my uncles workshop.

So i thought i would let you guys know that my cougar is wet and down, now i have to go around driving a POS FORD F150 that eats the [censored] out of gas
 

·
Registered
Joined
·
510 Posts
Discussion Starter · #3 ·
the state trooper was just getting down the exit ramp and seen me

after me there was probally 2-3 cars that got stuck to and then they closed down the highway north and south and they even closed parts of 494 and wakota bridge
 

·
Registered
Joined
·
1,270 Posts
Sorry about your car, man!
That storm sucked @$$...I didn't get into any deep water but I was on my way to my friend Jeff's house (Neil, I believe you met him at Bennigans) and my damned wipers stopped working when I was going 65 or I94W. Im so mad because I had it at a Ford dealership in Sioux Falls for a week and they said they couldn't figure it out. Anyone know any reputable Ford/Mercury places in Mpls?? I need to get it in soon.
 

·
Registered
Joined
·
510 Posts
Discussion Starter · #5 ·
i usally go right to the one in hastings since that is the closest one for me

never had a problem with them at all


btw you guys dont think this would be covered under insurance do ya?
i was thinking about giving them a call to find out
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top