New Cougar Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
324 Posts
Discussion Starter · #1 ·
Ok, I was driving around in my car and everything was running fine. Stop at a gas station to check my tire pressure, get back in, car starts, idles rough, dies. I start the car again, it idles really rough at like 50 rpm for and actually would for quite a while (at least 30 seconds), if I hit the gas it dies.

So my friend and I are trying to diagnose the problem, make sure the MAF is plugged in, reset the ECU, nothing. Then when I'm trying to start it again, I notice something. My fuel pump isn't priming. Now right away this would make us think it was the fuel pump, except for the fact that it would stay running for quite a while. But after a few more tries, it will no longer run for more than a second or two, so we're 99% sure we're talkin fuel pump. Especially since I've yet to replace mine.

Any insight would be GREATLY appreciated.
 

·
Banned
Joined
·
5,184 Posts
Sound about right to me, I would pull the cap off the fuel rail and push down( carefully, have a rag around it to catch potential spray) schrader valve to check for fuel in the line.
 

·
Registered
Joined
·
3,206 Posts
Fuel Pump fuse and all the others too!!!
 

·
Registered
Joined
·
124 Posts
You can easy check if your fuel pump is working by unpluging the fuel filter, be sure to hace something that catches all fuel.
there are 2 fuses in the engine fuse box that control the fuel pump.

this morning, i'd have the same issue, my car couldn't start but the engine sound ok, i heard the fuel pump work while opening the key, i checked engine box fuses and nothing, i was late to work somebody gave me a ride to my job and there called a mechanic friend (damn rare to do that) so he checked it and told me a fuse was burnt from the driver side fuse box, so can somebody tell me which damn fuse cannot make the car start, that's a kewl news so i can put a new thief switch from it.
 

·
Registered
Joined
·
324 Posts
Discussion Starter · #6 ·
Well today I went back and checked the fuel shutoff switch, or tried to. I see where it is supposed to be in my footwell but I sure couldn't see/feel anything like a switch or button, tonight I will go back and take off that little piece of interior trim for a better look. I also checked the fuel pump fuse, it was fine. I switched the fuel pump relay with the one right next to it, still no go.

Tonight I'm gonna push it to the shop and then unfortunately have to wait until monday for them to fix it.

I just got my car back on Monday from an $1,800 repair and then thursday night it breaks again :'(
 

·
Registered
Joined
·
2 Posts
I have the same problem how did you fix it , sometimes I get my car to start but it die after random time and dont want to start anymore ( no crank or crank but wont start). Wonder if you fixed you problem
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top