New Cougar Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey guys. I could really use some help. Ok. I’ve been trying to pass my smog for my 00 cougar 2.5l v6 versión. Had egr problema in the past but that’s besides the point. I hooked up the scan tool and codes pending are both p0420 and 430. I’ve had this problem before. But they actually turned on the engine light And it was only showing the 420 code. I took off the cat to clean it. And it actually worked. But like I said there was other codes. So I was trying to fix those. And once those were fixed the light came up again for the cats. So I changed the cat, cleaned the o2 sensors fixed some vacuum leaks. And drive the car for a while but monitor wasn’t ready. That’s when the pending codes came up. Only thing I can think of is an exhaust leak.
Sorry for making this long thought I’d share more of the story. Can someone help plz. Really am in need of desperate help. Trying to fix this ???
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
not sure how your smog works, but here its only a problem if the CEL is actually on. On my 00 on the down stream O2 i added a spark anti fouler spacer and ive had no issues
Yeah man I’m in Cali. So the strictest state 🤦🏼‍♂️ But I require for cat monitors to be complete and all of the other ones are complete except that one. And when I drove it. For a good while it was still incomplete. But that’s when those pending codes came on. And I want to get rid of them before they actually turn on the CEL. Any help. Thanks
 

·
Premium Member
Joined
·
4,013 Posts
Or do a virtual move to South Dakota or Florida. There's a whole industry built around it. (most of) My vehicles are registered in SD because Connecticut sucks.
 
1 - 6 of 6 Posts
Top