New Cougar Forum banner

1 - 4 of 4 Posts
J

·
Guest
Joined
·
0 Posts
Discussion Starter #1
ok, here's my problem...my battery light is on and flashing most of the time...my lights are dimming out and then at lower rpm's everything will be fine but even at low rpm's the battery light comes on sometimes. i took my car to autozone and the alternator and the battery checked out fine. but i think i have a wiring problem...this is what i need help with...i tried moving my battery to my trunk, then i decided not to so i'm not sure what has to be grounded to the battery and what to the chassis. when i put the battery back in the engine bay the wires were too short to reach the new terminal cause i threw the old one away. so what i did was take the thisck black wite from the engine to the terminal and then a piece of 4 guage wire from the terminal to a distribution block then from the distribution block i have a piece of 8 guage wire grounded to the chassis then i have 3 other wires in the distribution block...i have no idea what these 3 wires are buti'm pretty sure they used to be grounded to the battery, but i can't remember. what i would like if someone can is tell me what comes off of the negative battery terminal. i know that the thick black wire grounds to the engine, but i;m not sure where everything else goes...please help me.

99 mercury cougar
v6 2.5
automatic.

if you need any more info or could direct me to a wiring diagram please post here
 

·
Registered
Joined
·
5,817 Posts
Food for thought. Prior to my alt dying, it tested out just fine. We tested it at idle, at high rpm, and under load throughout the rpm range.
 
J

·
Guest
Joined
·
0 Posts
Discussion Starter #3
well i was on my way to work this morning and all of a sudden my radio turned off and lights went out, then followed some bucking and sputtering and alot of cursing and my car died. well i work in the middle of no where and had to be there by 6:30am. so i had a brisk 2 1\2 mile walk this morning to the nearest farmer's home to use the phone cause of corse cell phones don't have reception...he wasn't very pleased to see me at 5:45am. did i mention it was about 10 degrees this morning with a 0 degree wind chill? alternator dead...thanks autozone for telling me it was fine and thanks ford for the wonderful piece of equipment your design team created. they must have designed most of the parts for our cars the day after the christmas party.

later guys
 

·
Registered
Joined
·
5,817 Posts
Actually Ford has nothing to do with your alt. They are all rebuilt by a vendor that Ford hired. They have recently changed vendors due to a high failure rate in alts...for ALL Ford vehicles.
 
1 - 4 of 4 Posts
Top