New Cougar Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter · #1 ·
I officially hate Mercury right now. I noticed something was wrong when the car started to vibrate and the steering wheel was shaking. I pulled over to the side of the road, got out and looked at everything, it was like midnight though so I really couldnt see anything anyway. I got back in the car and did a 3 point turn and as I ended the turn I felt the car drop and I looked out the passenger side window to see my tire rolling in the street. Somehow the screws that the nuts go on that hold the tire on snapped in half, all 4 of them and they all had amazingly clean brakes. It really looked like someone had sawed them off. Passenger side fender was destroyed as well as the axel. Somehow the Buddy Club front barely got any damage other than a few scratches on the bottom. I never thought it was possible for something like this to happen in the way it did. Im really pissed and thoughts of finishing the Cougar and then selling it are definitly crossing my mind. I really dont know what do at this moment. I just have to vent.
 

·
Registered
Joined
·
1,222 Posts
holy sugar. that is funked up!!!


i go to drive to dinner tonight and as i go all my lights dim and the battery light goes on. i have a new battery and the alternator is 1 year old. it seems i have changed the alternator every year i had the car.
 

·
Registered
Joined
·
1,085 Posts
Eric: Wheels falling off is always normal. How did going to the dealer go?

J: lol horray for cougar alternators ... time for u to invest in a high output non oem alternator?
 

·
Registered
Joined
·
398 Posts
Originally posted by: datkidd247
I never thought it was possible for something like this to happen in the way it did. Im really pissed and thoughts of finishing the Cougar and then selling it are definitly crossing my mind. I really dont know what do at this moment. I just have to vent.

it's very possible if the lugs are overtorqued, which most "mechanics" will do by using air tools to tighten down the lugs. If the car was at a dealership recently i'd try barking up their tree since it's their fault, otherwise it's pretty much on you. Sorry man.
 

·
Registered
Joined
·
1,222 Posts
Originally posted by: 99CougarNy
J: lol horray for cougar alternators ... time for u to invest in a high output non oem alternator?
yeah i contacted a company in TX the makes their own and have a lifetime guarentee. i'm broke right now so its gonna have to wait.

when i change it...it will be my official fourth alternator.
 

·
Registered
Joined
·
1,222 Posts
i was thinking the bolts were over torqued too. when i just got my new tires. they were putting them on and the guy comes out and was like "oh one of your bolts snapped, probably from rust. it cost $30 for a new one." i just gave him a look and he was like oh but i won't charge you for it.

damn right you won't
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #8 ·
Actually the dealership has not had my car since I bought it in February. I could understand if one or two of them snapped off but this was all 4. I just found it weird that all 4 would snap at the same time. I havent had my front tire off in around a month so I dont think it would have taken this long for them to give. I dunno, it just seemed too weird.
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #10 ·
Haha nah, no lawsuit. Im not as mad as I was originally. Im actually happy that all that such a small amount of the car got damaged. It turns out that the axel will be ok and I just need a new rotor, spindell and bearings which I was able to pick up from a junkyard for 50$. The shop said the car should be done middle of this week, hopefully theyre right.
 

·
Registered
Joined
·
398 Posts
Originally posted by: datkidd247
Actually the dealership has not had my car since I bought it in February. I could understand if one or two of them snapped off but this was all 4. I just found it weird that all 4 would snap at the same time. I havent had my front tire off in around a month so I dont think it would have taken this long for them to give. I dunno, it just seemed too weird.
it could take 2 hours, 2 years. or two weeks for the stud to fail...with one stud snapped, the others stand a greater chance of breaking as well, especially if not torqued correctly. Also remember, not enough is just as bad a s too much.
 

·
Registered
Joined
·
415 Posts
quick question for ya....did you actually take the lug cover off and look to see if the lugs were broken?

I'm assuming you have the factory wheels based on your sig pic. That vibration was the start of the lugs snapping, one after the other they fail. This has happened to me a few times but I never let it get bad enough where they all failed. If they were overtorqued then the stress load on each was greatly increased and consequently when one failed the others were very quick to follow.

If I don't do the work on my car which is rare I always check the torque on them, not only that if I feel they have been torqued too much I will replace them just to be safe, but thats just me.

Don't hate Mercury because some jackass over torqued your nuts :biggrin:

Just be glad you weren't doing 50 at the time it happened...

Good luck.
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #13 ·
I actually did check but nothing caught my eye. The guy that towed my car and put the new stuff on it said that overtorqing was not the case here. He said that most likely the nuts were loose. I seemed to disagree with him there. Either way its all good now cause I got the car back running. Im just cruising with half of a fender until the z3s I ordered come in.
 

·
Registered
Joined
·
398 Posts
well if the lugs were loose, you would have had some noise/vibration from the wheel being allowed to travel, and you should also notice some threads stripped off where the wheel would have rubbed on the stud.
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top