New Cougar Forum banner

221 - 227 of 227 Posts

·
Registered
Joined
·
2,625 Posts
Discussion Starter · #221 ·
So I started messing with the car some more.
The rest of the body kit is on temporarily.
And I pulled a bunch of rusted rear parts out and started working on putting it back together.
So kit was first

Then all this came out.


Then this started making its way back in.

Still find it funny when you look at the stock sway bar and how much smaller it is.

Then these
got 1 wheel on the back. The strut that was on the driver side is stuck in the knuckle and it got dark on me.
hopefully tomorrow I can get the driver side back on so this gap goes away.
 

·
Premium Member
Joined
·
3,749 Posts
Glad to see a car going the right direction. You need to get it to Cougarfest. Its going to be a big year for us and we will need all the representation we can get.
 

·
Registered
Joined
·
2,625 Posts
Discussion Starter · #223 ·
I'm hoping. I'm working my butt off trying to get this thing running. It's been parked since like 2013 so I'm having to fix ALOT of stuff just from it sitting. I was also going to use it for the AWD project at first so it got totally stripped. I'm a full time student right now and will be around cougarfest time as well so time off wouldn't be an issue this year. this year is going to be about if the cars running at a point I feel comfy enough to make the trip and if I have the money for it and if we can find a babysitter for the weekend. lots of key factors however the fact of work keeping me from it this year isn't an issue.
 

·
Premium Member
Joined
·
3,749 Posts
Hey Rooster, your post in the other thread reminded me of this...That Irish guy with the Yellow Supercharged 2.5l Escort is using Microsquirt...might be worth picking his brain if you're stuck with the EMS stuff.
81392

I imagine he would be easy enough to track down either through the linked forum or through Youtube...
 

·
Registered
Joined
·
2,625 Posts
Discussion Starter · #225 ·
Holy thread revival batman!!!
I actually got it to start. Idled long enough for the ECM to adjust the fuel trims fairly close. Then it stopped reading the crank signal again.
I think my issue is actually the toothed gear the crankshaft reads. Looking through the crank sensor holes the teeth arent directly under the hole. They're more off to one side. Meaning when I switched the gear I put it on backwards lol.
 
  • Like
Reactions: mmc757

·
Registered
Joined
·
2,625 Posts
Discussion Starter · #227 ·
Yeah well I Really needed to drop the subframe to do control arms and rebuild the steering rack as well as make new brake lines to replace the ones on it. As well as probably replace the timing cover, I'll probably just drop the engine out the bottom while its apart and fix it all.
What happened was the directions I was following said flip it instead of rotate and Captain Morgan helped me follow the directions exactly. Lessoned learned.
I've also since then switched from megasquirt to MaxxECU so contacting him possibly could help or possibly not.
Good looking out though.
 
221 - 227 of 227 Posts
Top