New Cougar Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
2,950 Posts
Discussion Starter #1
The cougar really flies when its minus one billion degrees outside, but i'm a tropical people dammit, i can't take it!! too bad there is all that snow and ice on the road, otherwise it would really be fun to push our cars in this weather...oh well....i'll just have to settle for doing donuts in the parking lot :p
 

·
3L Roush
Joined
·
4,387 Posts
At least you HAVE your car! :(

I was getting ready to go to the Leaf game on tuesday night, so I went out and started the car and let it sit for 5-10 minutes. I get outside, back out the driveway, start to pull forward and.......DEAD! The car DIED! No power! The radio worked, the lights worked but thats it. I put the key in to try and start it again, and it wouldn't do ANYTHING. I couldn't even get the car out of PARK so I could move it off the street!

Needless to say, it was towed to Pine Tree Ford and its been sitting there since tuesday night UNTOUCHED! Thats right, they haven't done anything! I hate that dealership! :mad:

Thank God for ESP! :biggrin:

Anyways, just thought i'd vent. I hate the cold too. ;)
 

·
Premium Member
Joined
·
1,754 Posts
The cold sucks. I don't know how my car would enjoy it though since it hasn't moved in a week and a half since it got back from the dealership (everything still works, at least now it does).
 
S

·
Guest
Joined
·
0 Posts
.........mmmmm....gotta love 4x4.....pity that my car has this compulsion to tell me the door is open when they are shut. i think this is her complaining....cold sux big time butt.
 
L

·
Guest
Joined
·
0 Posts
Well What Can I say... Love the heated everything... only thing my battery... she no like the cold... so guess who had to get one of those dun.... but now she coasts in the snow... and Advance Trac... even when i try to fish tail... it keeps me in check...

On a side note... the company just gave me 500 bucks to go away... so Bonaire here i come
=D
 

·
Registered
Joined
·
2,950 Posts
Discussion Starter #8
haha...thats why you need a yellow top dude! most bad ass battery ever! I drove my car around for two days with a dead alternator and the yellow top kept me going!

also, with my kumho snow tires on, my car handles better in the snow than my jeep (which is 4x4)....just goes to show you that the most important part of handling is the part that touches the ground! ;)
 

·
Premium Member
Joined
·
6,085 Posts
Mike.....your voltmeter was the problem???? lol

My beater has thankfully held out thus far, allthough it's taking it's time and not starting right away lately. Mind you, it hasn't been driven enough to get completely warmed up in the last 3 days and I get a CEL occasionally.....but oh well, just needs oil :)

I haven't been happier driving this beater. Not to mention if I drive it for a year, my insurance drop alone will have paid for the car. Not to mention it gets better milage than my cougar and it's a 2.6L AND has a small gas leak!!
 

·
Registered
Joined
·
220 Posts
Originally posted by: Mike


Needless to say, it was towed to Pine Tree Ford and its been sitting there since tuesday night UNTOUCHED! Thats right, they haven't done anything! I hate that dealership! :mad:

Cambridge ford is really really bad for service, i went to fix my e-brake, car comes out 51 dollars later and nothing is fixed, i was charged 51 dollars for labour, i brought it back the next day and told them that it wasnt fixed, they looked at it again and said the cables needed to be replaced, parts are 100 and labour is 142...just a bit of bs...dunno what to do
 

·
Registered
Joined
·
540 Posts
My car hated the cold... made lots of wierd tinn noises when i started it.. the ***** is in a warm garage right now.... so i hope she's happy.. :)
 

·
Registered
Joined
·
656 Posts
Originally posted by: kittykatcanada
Originally posted by: Mike


Needless to say, it was towed to Pine Tree Ford and its been sitting there since tuesday night UNTOUCHED! Thats right, they haven't done anything! I hate that dealership! :mad:

Cambridge ford is really really bad for service, i went to fix my e-brake, car comes out 51 dollars later and nothing is fixed, i was charged 51 dollars for labour, i brought it back the next day and told them that it wasnt fixed, they looked at it again and said the cables needed to be replaced, parts are 100 and labour is 142...just a bit of bs...dunno what to do
I know a good dealership you should try!

:biggrin:
 

·
Registered
Joined
·
2,950 Posts
Discussion Starter #14
i'll vouch for that, lance's dealership is the shizzle ma nizzles ;)
 

·
Rockin' Mom-mobile
Joined
·
8,010 Posts
Don't worry Ajay, I wasn't made for the cold either. :( When I give up and move to Hawaii, you can come with me ;)
 
1 - 15 of 15 Posts
Top