New Cougar Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1,437 Posts
Discussion Starter · #1 ·
So the Batt light has been coming on at around 5000rpm for a few weeks now so I figure I better get an alt. A fellow member gave me his old one so I took it to a rebuilder last weekend, $100 later I had a nice shiney rebuilt Alt. So Sled and I put it in today and also did the red wire cut and splice mod. Put it all back together, drive it and get to the first stop sign and the guages start doing whacky things, put it back in the garage let it run for a few min. then shut it off. We then notice a hissing/boiling type sound coming from the battery:cover: WE both know that isn't good from Sled's past experience. (another story) So we take the battery and old Alt to Autozone and everything checks out fine. The green "eye" on the battery is pretty much black now though. So we check everything over again including the wiring mod and decide to put the old Alt. back in. Now with the old Alt back in and the battery hooked up the car is running fine, but the battery light still comes on at 5000rpm. So I plan on calling the rebuilder and telling him what happened, hopefully he has an easy answer to why his rebuilt alt is doing funny things to my cars Elec. system. Any input from anyone would be appreciated.
Thanks, Jeff.
 

·
Administrator
1999 3.0 SilFro
Joined
·
24,717 Posts
Hmmm. Was it rebuilt to the same specs, or did you have it re-wound to a higher output?

Definitely something bad about the rebuild, if the old alt calms it all down again. I would like to see a side-by-side test of the old and the "new" alternator, to see if there are any differences they may not have noticed.

I'm going to do the wire splice thing to my car soon. This pulsing dash light thing is driving me nuts, and since the weather is getting colder, it's getting more pronounced.

These friggin' cars and their electrical gremlins. I suppose that's why we love them :rolleyes:
 

·
Registered
Joined
·
4,201 Posts
I hope we get another fairly warm day here soon. I wouldn't mind doing that alternator wire splice mod as well. But the cold and my hands don't agree with each other. How long does it take to do that anyways?
 

·
Administrator
1999 3.0 SilFro
Joined
·
24,717 Posts
I smell a mod meet...who has a heated garage?!!
 

·
Registered
Joined
·
4,201 Posts
Originally posted by: Bennett9000
I smell a mod meet...who has a heated garage?!!
I do...sorta...i have heaters in my garage...but there's no way in hell we'll fit our cars in it. Even if we could we would barely be able to walk around them let alone get underneath them.
 
1 - 5 of 5 Posts
Top