New Cougar Forum banner
101 - 118 of 118 Posts

·
Registered
Joined
·
2,669 Posts
Discussion Starter · #101 ·
Thanks. Getting ready to start this timing cover project in a bit. Put the car back on the driveway so I can work on concrete again. Man I forgot how driving one of these feels.
 
  • Like
Reactions: venomcougar

·
Registered
Joined
·
2,669 Posts
Discussion Starter · #103 ·
Yeah thats not bad. It's outdated but I like the body kit cars. Fortunately, I'm building it to make me happy not whats up to date.
Unfortunately the sun and weather has played hell on the old girl for 7 years so I got ALOT to fix it.
 

·
Registered
Joined
·
2,669 Posts
Discussion Starter · #104 ·
Finally got to put something in the fuel cap hole too although rain stopped me before getting it all the way in.
 

·
Registered
Joined
·
2,669 Posts
Discussion Starter · #105 ·
Accomplished a little on this timing cover today
 

·
Premium Member
Joined
·
4,013 Posts
That's the paint I used on my SVT UIM. Its nice.
 

·
Registered
Joined
·
2,669 Posts
Discussion Starter · #107 ·
New tensioner and idler. Now I gotta figure out how to get the crank seal out without killing the paint.
At least thats behind the crank pulley so a small scuff wont show.
That one got cooked baking the paint which is why it didnt get changed prior.
 

·
Premium Member
Joined
·
4,013 Posts
Cut the paint with a scribe or an exacto knife before popping it out.
 

·
Registered
Joined
·
2,669 Posts
Discussion Starter · #109 ·
Yeah I'll have to try that. I'm probably going to give it another day to cure before I try.
Still have more stuff to paint anyway.
 

·
Registered
Joined
·
2,669 Posts
Discussion Starter · #110 ·
I officially have the stock fuel pump working with the aftermarket lines.
 

·
Registered
Joined
·
2,669 Posts
Discussion Starter · #111 ·
She definitely has a hell of a lope to her. I need to work out the tuning in it cause thats crazy.
 
  • Like
Reactions: wadespencer99

·
Registered
Joined
·
2,669 Posts
Discussion Starter · #112 ·
Finally test drove today around the block. She needs some work still but everything appears to be working fine.
 

·
Registered
Joined
·
2,669 Posts
Discussion Starter · #113 ·
Definitely getting there.
 

·
Registered
Joined
·
2,669 Posts
Discussion Starter · #115 ·
Working on tuning it now. Fuel trims were so far off it pegged out the wideband when I started it. And it would appear the alternator died.
 

·
Registered
Joined
·
2,669 Posts
Discussion Starter · #116 ·
Alternator is working. The engines getting hot and the alternator is stopping when it gets so hot. It appears my low speed fan has crapped out on me.
 

·
Premium Member
Joined
·
4,013 Posts
Sounds like it might be a cable degredation issue. One or more sections of cable may be losing continuity when it gets hot. Our original battery cables are all pretty well past their reasonable service life at this point, especially in humid climates.
 

·
Registered
Joined
·
2,669 Posts
Discussion Starter · #118 ·
Yeah I replaced from the battery to the starter as well as from the battery to ground with 2 gauge cable. I still have to do from the starter to the megafuse and from the fuse to the Alt. Figure while I'm there I'll do the mod at the ALT for the charging due to lights flashing in the dash.
Main concern right now is the fan not working.
 
101 - 118 of 118 Posts
Top