New Cougar Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter · #1 ·
Ok so I finally figured out that this little light that looks like a trash can is my coolant light. But anyway it comes on all the time and stays on while I drive and I have no idea why. The coolant is up to the line, so what's the deal. How do I make it go away?
 

·
is a pop sensation
Joined
·
13,676 Posts
The coolant light is a little overzealous. Add a little extra coolant to the tank so that it is slightly overfull, the light should go away.
 
G

·
Do you park on an incline? Thatll trip the stupid sensor, it always happens to me when i park at my house. Its no biggy
 

·
Registered
Joined
·
54 Posts
Discussion Starter · #4 ·
No I park on a flat surface, but I mean it just comes on when I am driving. But I will try adding a little more to see if that helps though.
 

·
Premium Member
Joined
·
2,810 Posts
even if you're driving up an incline, it'll trip it..
 

·
Registered
Joined
·
64 Posts
I had the exact same problem and it was driving me crazy. I added a little more coolant to the reservoir and the "problem" went away.
 

·
Registered
Joined
·
5,519 Posts
same with me mine went away with a few shots of collant added
 

·
Registered
Joined
·
54 Posts
Discussion Starter · #8 ·
I added a little extra coolant last night and gues what, NO MORE LIGHT!! Thanks, everyone had me thinking my censor was busted or whatever.
 

·
Registered
Joined
·
388 Posts
woohoo I will try this, I had this prob for like a year now. I thought it was like the CEL so I just ignored it. I knew my fluid's were good but it still bothered the hell out of me.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top