New Cougar Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
778 Posts
Discussion Starter · #1 ·
Just did LED swap on door/window switches. However when I put them back I tested them to see if they worked. The came on for like a sec, then they turned off (even though the key was on "ON").

Now the window buttons are not working, neither is the light coming on. The lock unlock button still works but no light coming out of those either.

What could be the problem? Fuse burnt out? This doesnt seem to have happen to anyone else who did the LED Swap thing.
 

·
Registered
Joined
·
3,206 Posts
Check your fuse panel in the inside of the car. #21 its a 40 amp. on the only orange one in there! Good luck.
 

·
Registered
Joined
·
8,235 Posts
You used the right resistors? and your not crossing any of the contacts in there? If you tried it with out a resistor they will come on for about 2-10 seconds then burn out.
 

·
Registered
Joined
·
8,235 Posts
Its been a while and my memory sucks, but i think the stock lights had built in resistors. Im pretty sure i had to put resistors in....
 

·
Registered
Joined
·
778 Posts
Discussion Starter · #6 ·
So the fuse is INSIDE - oooo - i looked everywhere in the fuse box outside but counlndt find it.

So where is the fuse box insde the car?

Well according to the LED how to, it didnt say that I had to put resitors cause the oem ones where sufficent. And plus before I connected everything I tested it with a battery and they all worked fine.
 

·
Registered
Joined
·
778 Posts
Discussion Starter · #9 ·
Originally posted by: EricF
under the dash is the fuse panel. it has a sort of button, push it and the panel swings down.
What button - I tried all night and I still cant get the stupid door down. It is annoying me - hindering my progress or at leat hindering my trougle shooting! Sucks.

So, when you say button you mean the thing on the side you can insert a flat head and push up? Would you happen to have any pics? (its a shame im having trouble with this cover - lol)
 

·
Registered
Joined
·
8,235 Posts
your lucky im bored tonite...

thats the fuse box... to the right is that white plastic area... with the D shaped knob... pull on that.
 

Attachments

·
Registered
Joined
·
778 Posts
Discussion Starter · #11 ·
You so kind!! lol - thanks - I feel................sheepish. :goofy:

Thanks a lot man - was way easier - I was trying to stick a flat head in the groove on the black part.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top