New Cougar Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
88 Posts
Discussion Starter · #1 ·
I changed the LEDs in my car to blue...however I've replaced my trunk popper light once already and now it's out again!! Anyone know why that is happening? I thought that LEDs didn't wear out!

ALSO, the computer buttons in My '02 don't have LEDs in it. Is that right or am I missing them?
 

·
Registered
Joined
·
3,030 Posts
I don't know much about the trunk popper but your computer should have a little circuit board in it. What you need to do is a little complicated. Basically you need to put big enough holes in the board where all the lights are and fit the LED's in there. You also have to make room for them in the bottom plastic piece with a soldering pen and file down some of the clear plastic points so the LED's don't disconnect when you press the button.

I was just trying to give you an idea. I'm sure someone on the forum has a highly detailed How-To.

Good Luck :thumbsup:
 

·
Registered
Joined
·
1,264 Posts
The computer buttons are a little tricky, but what was said above is the right idea. You have to make the existing holes where the lights are now big enough to fit the led you're adding (probably 3mm). Then you solder the led's in place just like the existing lights were.

As far as the trunk button, I changed mine with no problem. That button has an internal resistor, so you don't have to add one, but if you don't have enough resistance to an led it will burn out. Take it back out and check your soldering points, and make sure you didn't cross polarities.
 

·
Registered
Joined
·
1,036 Posts
About your trip computer IT DOES have LED's Just Tiny ones, that don't look like conventional LED's.


About your Trunk button, try replacing the resistor in the switch, it could be bad.
 

·
Registered
Joined
·
1,142 Posts
for the trunk popper. do you have your headlights on when you are checking it. I did Crispys car and NascarSiges and stupid me thought I f'ed up cause I couldn't get them to work ugh.... BTW, don't change complete LED's on a garage floor under a timeline lol

You could have a short or your solder could be bad. Or maybe you damaged the resistor while installing.

As for the computer buttons... They are LED's. They are surface mount. I have found a company that sells surface mount and I bought all my LED's from this company so ALL my LED's match. Looks cool as hell. I don't have any pics here at work.

I bought them from www.eled.com Good people to deal with.
 
1 - 5 of 5 Posts
Top