New Cougar Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
204 Posts
Discussion Starter · #1 ·
Interior light and guage display fuse

Does anyone know why my fuse for interrior lights and my gauge keeps on blowing?

I noticed that the fuse blew after I left the overhead light on for 3 hours. It was still working when I started the car and by the next day it was not working anymore. I pulled down the fuse box and found the blown, fuse, but everytime I stick another fuse in there it blows right away. When I disconnect the overhead light and put the fuse it, it is ok, but once I connect the light it blows. The light works for a little bit before the fuse blows.
 

·
Registered
Joined
·
8,235 Posts
humm thats an odd one, assuming your putting the right size fuse in, and the over head light is pluged in right (dont think you can reverse it) the only thing i can think of is somethings cross connecting the wires... either a some wire is loose and touching another, or theres a bit of metal where it shouldnt be. Hopefuly its something you can find ...worse case senario some how a wire got over heated or worn and its cross connecting another wire or the body... but all of thats just a guess.
 

·
Premium Member
Joined
·
1,466 Posts
mine does the same thing! it sucks! lol i tried 7.5 10 15 20 25 and they all blow lol so theres something messed up. but its weird cause sometimes it will work and take a fuse then it will last for like a week but then BAM no interior lights lol!
 

·
Registered
Joined
·
204 Posts
Discussion Starter · #5 ·
Yeah, I disconnected my overhead light so my clock can work. Just dark kinda at night. Does anyone have another cougar around they can swap out the overhead light and see if the short is in the assembly or the cabling?

Andy
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top