New Cougar Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
3,309 Posts
i zip tied the hell out of mine onto my car. like 01blkcat said, put them behind the pinch weld and they're not THAT visible, although you can still see them. if you can still see the lights (like on my car, even though i DO have sideskirts) just put some black electrical tape on the side of them and it'll hide the bulbs somewhat.
 

·
Registered
Joined
·
4,973 Posts
I just installed these last week. Took me 3 hours to do, but I already had all the holes drilled from my old underbody neon tubes. With the LEDs you have to be carefuly because the tubes aren't completely round and you have to make sure the LEDs point directly downward or maybe even a little outward. I found it a good idea to use those special clamps (if yours came with any...I got the streetglow LEDs). They're the plastic clamps that have a piece of material taped in them to keep the tubes from turning. Wiring them was a pain because I had a control box and all the tubes had to be plugged into it, so it wasn't just a positive and negative wire being run into engine bay and through the firewall...it was a fat cable with about 5 wires in it..for EACH tube. need any help during install PM me.

Mike
 

·
Registered
Joined
·
3,309 Posts
ya, the freakin plugs were a pain to get in through the firewall. where'd you mount your box at?
 

·
Registered
Joined
·
4,973 Posts
I stuck it right across from the firewall, on the dash piece that's above your left leg.

Mike
 

·
Registered
Joined
·
3,309 Posts
Originally posted by: 99CouGSweetRide
I stuck it right across from the firewall, on the dash piece that's above your left leg.

Mike
yep, that's where i mounted mine as well.
 

·
Registered
Joined
·
4,861 Posts
Originally posted by: NARD
I'm really struggling with the routing for cables from the engine bay into the passenger compartment! Which route did you all take? Also how to run the wires from the LED's to the box? Thanks.:banghead:
If you've got an automatic, there is a pear shaped grommet behind the right strut tower. If not, drill a hole and run them through. You'll find how-tos on teamNECO and CougarDB for that.

Otherwise, you could run everything through the grommet in the bottom of the trunk and then back up to the front, if you wanted. Just a thought.
 

·
Registered
Joined
·
586 Posts
Discussion Starter · #11 ·
Right, update, great advice about the gromet in the rear! Have totally ignored the engine routing idea and have stolen power from the CD changer in the trunk, and then wired under carpet to the front to mount switch and control box. :biggrin:
All that's left now is to mount LED's and run cables through rear end gromet. Pics will follow.
Thanks for all the advice.:grouphug:
 

·
Registered
Joined
·
4,973 Posts
shoot where is that grommet in the rear? Is it under the spare tire? Never looked under there.

Mike
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top