New Cougar Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
101 Posts
Discussion Starter · #1 ·
I cannot determine after reading all of these postings and I mean all, where the problem is with that car.

Car has 45k miles on it. About 7k miles ago 4k miles after having Merchants replace the fuel filter I notice that when I cracked 3500 rpms it started to buck under a half tank. Then one night on my way home from drinking the meter said 148 miles left and the cel blinked and the car stalled. What a nice walk home in the rain. The next day I went and put two gallons in and it started right up.

Now the car bucks/ hesitates @3000k rpms when there is a half tank in it. I have yet to put it down to a quarter cause I dont want it to stall.

I HAVE READ all postings and cant determine whether it is the pump, filter, plugs, or wires.

No garage can tell me what it is because there is no code coming up.

I am good on brakes, rotors, intakes and exhausts, but am extremely afraid of tackling the fuel pump by myself!

Can anyone give me some pointers on whats wrong before I go broke. I am a sales guy and drive about 600 miles a week and cant afford to be stranded somewhere.

Oh yeah its an ATX. If that matters at all.

I want to tackle the bang shift but the car needs to run right first!!!!!!!!!!!!

PLEASE HELP ME!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
If you live around BURLINGTON and want to give a hand at this let me know( AND YOU HAVE DEALT WITH THIS IN THE PAST).... Id be willing to work something out:beer::biggrin::beer:
 

·
Registered
Joined
·
4,973 Posts
Do u have an early '99 or a later '99? I think the earlier ones had different fuel pumps that lasted longer because they were made differently...or something like that...Fett would know.

Mike
 

·
is a pop sensation
Joined
·
13,672 Posts
A shop should be able to check if it is a fuel delivery problem by checking the fuel pressure. If it is low then you most likely have a problem with the fuel pump or filter.
 

·
Registered
Joined
·
5,817 Posts
If you have a later 99, then it sounds like a clogged fuel pump. Replace it.

If you have an early 99, then it sounds like IMRC. Both problems have the same symptoms.
 

·
Registered
Joined
·
4,973 Posts
Originally posted by: Neil
whats this?

return system cars have better fuel pumps? :confused:
:biggrin:

Mike
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top