New Cougar Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1,608 Posts
Discussion Starter #1
Here is the situation...

My car has no headlights in it and no grill....

I can not pop my hood... the pull inside just comes out when I pull on it... it feels like the hood cable has become dissatached....

When I pull on the yellow tab underneath the hood to pop it it doesn't do anything...

I need to get my hood popped.... anyone know how to get it open?? PLEASE!!! If you know a solution please post it on here :(
 

·
Registered
Joined
·
2,552 Posts
I had this same problem this past summer.
open the panel that covers the latching mechanism on the inside of your car.
there's a rubber piece that should be anchored to a small notch in the plastic.
yours has most likely popped out like mine did.
pop it back into place and then pull it til the hood pops (as it normall does).
I then had to spray some lithium grease into the mechanism under the hood.
the problem was that the latch mechanism was metal rubbing on metal under the hood and it wasn't moving smoothly enough, so the latch in the interior was trying too hard to pop it and it kept getting pulled out of place.

I'm sorry that this is such a piss poor explanation of what happened.
if I was at home right now, I'd take detailed pictures to show you exactly what I mean.
 

·
Registered
Joined
·
1,413 Posts
This is a common problem. Go to the inside latch and take the cover off. You can pull the cable to release the hood. You can also look/study the latch and tell how it goes back together. This happens to me every so often.

edit: yeah like frenchblue said...she beat me too it...
 

·
Registered
Joined
·
1,371 Posts
Originally posted by: frenchblueC2
I had this same problem this past summer.
open the panel that covers the latching mechanism on the inside of your car.
there's a rubber piece that should be anchored to a small notch in the plastic.
yours has most likely popped out like mine did.
Yep, there are almost little forks that hold the cable on. Just pull the cable back up on top of the forks (towards the firewall) and viola - pasta in a minute.

[GnuLoCo]
 

·
Registered
Joined
·
191 Posts
I JUST USED ZIP TIES-ZIP ONE WHERE THE CORD MEETS THAT YELLOW KNOB-THEN LOOP ANOTHER ONE AROUND THE FIRST ZIP CORD ITS GHETTO BUT FUNCTIONAL
 
S

·
Guest
Joined
·
0 Posts
please turn off your caps lock before someone accuses you of yelling ;)
thanks.
 

·
Registered
Joined
·
3,028 Posts
anybody got a permanent fix for this? i hate having to pull the cover off and snap it back in place again...
 

·
Registered
Joined
·
5,817 Posts
Originally posted by: gamiller
anybody got a permanent fix for this? i hate having to pull the cover off and snap it back in place again...
This is hard to explain, but I was having that problem every time I tried to open my hood.....it got to the point where I just completly removed that shield on the kick panel all together. I did this and haven't had that problem in two years. Like I said, this is hard to explain, but once you look at it you will see what I mean.

As you look at the handle and cable, you can see the problem where the cable stop pops out of the plastic holder on the handle. Drill a small hole next to the holder and use zip ties to ensure the cable will not pop off again. I know that is wicked vauge, but once you look at it closely, you will see what I mean.
 

·
Registered
Joined
·
902 Posts
I just bought a new one from a junkyard.. I thought I was the only one with the problem :)
 
1 - 10 of 10 Posts
Top