New Cougar Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
Hello everybody !

the HVAC control panel of my Cougar does not works (is the LCD european style, see picture below).

The last weeks, the HVAC control panel worked perfectly in the mornings (cold exterior temperature), but in the afternoons after several hours under the sun, the HVAC control panel does not worked.

Finally this week, the HVAC control panel does not works anymore.


When I turn the knobs and press the buttons, it does nothing:
  • the LCD screen show nothing.
  • the illumination of the LCD screen is always off (even if I turn on the headlights).
  • the blower does nothing.
  • the AC clutch compressor not activates.


I have checked (including a wiggle test) all the fuses of the two fusebox (specially the fuses number 23, 34 and 37 related to heater blower and AC system) and is all Ok.

I have checked also the blue color relay R3 (related to AC) and replaced it with a new one. The relay works ok (activates when I turn on ignition switch)

I have do a wiggle test of the rear connectors and cables of the HVAC control panel, but still not works.


Please, has anyone had the same problem?
Any help will be appreciated.

Thanks in advance and sorry for my bad English.



My car is a 1998 Ford Cougar 2.5 manual transmission.
This is my HVAC control panel:

 

·
Registered
Joined
·
2,763 Posts
Check the european ford cougar forum. That control panel wasn't ever an option here and the cougar doesnt even exist for the 1998 model year here.
 

·
Premium Member
Joined
·
4,427 Posts
I think the UK forum has some ownership issues that have made joining difficult, this forum is probably the best maintained right now.
Most of us are in North America so have little or no experience with that panel.

It honestly sounds like an electronics failure though. You made need to replace the panel. You might try opening it up to look for loose or broken connections, but I would be surprised if you found it.
 

·
Registered
Joined
·
2,763 Posts
I cant tell if the numbers still show up and just dont illuminate. If thats the case could there be a bulb for the LCD that burnt out like with the LCD screens in the gauges?
 
1 - 4 of 4 Posts
Top