New Cougar Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
107 Posts
Just trying to help here.. but are you sure its the fuel pump? Could it be the fuel filter? Mine got clogged on another car.. the car would bog down and almost die at times.. changed it and the car ran good again.
 

·
So its begun.....
Joined
·
16,838 Posts
Who the hell is Holly?:shrug:
 

·
Registered
Joined
·
397 Posts
what ever just pick on me because in the got dam mexican right ????:mad:


ok but back to the subject i got to changing my filter out first to see if that was the problem or part of it and guess what i found coming out of the filter (other then the gas) ALLOT OF DIRT
 

·
Registered
Joined
·
397 Posts
well i its still doing it now but not as much as before!! but i just bought some autolites (double plats) to see it that helps out some :thumbsup: ill keep u posted

and if it is the pump i have some one that can get on for me for less then the dealer and i think its a walbro or something like that
 

·
Registered
Joined
·
107 Posts
Hope it helps Vick.. maybe run a fuel system cleaner too.. might have a clogged injector..
 

·
Registered
Joined
·
397 Posts
hay update: the cat is purrrrring again she's running allot better now

im so pissed off at my self cause i had 2 plugs that where off gap allot and all of them were really burnt up
so i think that was the got dame problem

i didn't really feel any bogging any more but it doesn't mean that its not happening i don't know i kind of had my foot on the gas since i hadn't felt that power in a long time :)
 
1 - 12 of 12 Posts
Top