New Cougar Forum banner
1 - 8 of 8 Posts
G

·
Discussion Starter · #1 ·
i've decide to try something today since i have a friend working in exhaust we kept stock Cat and resonator in the middle then we split the line to make a dual exhaust we remove the muffler from the exhaust but now i have a MAJOR power lost anyone know why ?
 

·
Registered
Joined
·
5,817 Posts
Hrm, I would guess that you lost backpressure. But I really don't know enough about exaust to know. Puck Puck is very knowledgable, maybe he can help.
 

·
T3/T4 60-1
Joined
·
8,015 Posts
can you describe more about the exhaust... did you use the same size piping at the split.... did you put two mufflers after the resonator? did you check for leaks anywhere
 
G

·
Discussion Starter · #4 ·
yes i use the same size and i didnt change anything in Cat or the middle resonator but we made a y just like the Yodude exhaust and put 2 tip at the end no muffler anywhere on the line and im sure there is no leaks anywhere but im sure i have lost LOT of power
 

·
T3/T4 60-1
Joined
·
8,015 Posts
if you have no leaks and no muffler, you should be making MORE power with much more noise... the resonator is just like a "barely muffles muffler"... the only other thing i can think of is that you now have an obstuction in the pipe somewhere stoping the flow of gases to get out.... i'm assuming then the only work that was performed was putting the Y pipe in and running new pipes with tips from the back.. i'm gonna say the Y-pipe has a kink in it or was not installed properly....

is the unit welded or clamped on?

If clamped on get under there, take it off and look inside with a flashlight
 

·
T3/T4 60-1
Joined
·
8,015 Posts
you should always pull the neg battery cable for 10-15 mins after EVERY mod
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top