New Cougar Forum banner

1 - 8 of 8 Posts
Z

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Hi all =),

I've some problems with the alarm system (i believe) on my cougar, please help!! If it has been asked before (maybe I'm not searching for the right thing), would someone be so kind to point me to the post please? =)

I noticed my alarm LED (the red one which usually just flashes when I turn off the car) is ON constantly since yesterday, and the power locks / keyless entry features are gone. I tried changing the fuse but it's blown right away. I constantly have clicking sound when I press / release on the brake no matter what gear I'm in.

Can someone please tell me if this is a big problem or not?? can I wait until my next big maintence?? the last service / maintence I did was the 30K one. When should I go for the next maintence??

Thank you very much in advance!! =)

Amy ^_~
 

·
Registered
Joined
·
1,166 Posts
You have an electrical problem. There is a reason that you are blowing your fuses right away. There has to be a short somewhere. Take it in to have it looked at if you don't have any electrical wiring and troubleshooting experience. For the clicking noise... Do you have an automatic? Mine does this too - it always does it in park, and once in a while it will click all the time when I am braking. It is just a single click when you put your foot on the pedal, and another single click when you take it off. I took mine apart to see if I could fix it. What is causing this on my car is the locking mechanism that stops you from shifting out of park unless your foot is on the brake. When you press the brake the lock disengages and makes the click noise when it snaps into place. When you let off the brake it will click again when it goes back to the original position. I did this while looking at the switch with my dash apart, and there doesn't seem to be any harm in it. It is just noisy! And since it only happens to me when I am shifting from park - I'm not too worried about it. I would get kinda annoying if it happened all the time though! Good luck.
 
Z

·
Guest
Joined
·
0 Posts
Discussion Starter #3
clicking sound: yes I've an ATX =) .. and it USED to only click when I'm shifting from "park". but ever since yesterday it's non-stop clicking every time i press / release the brake!!! it's getting annoying ... :(

electrical problem: since I know nothing about fixing my car ... I guess it's time for me to take it to the shop / dealer again ... sigh ...

does anybody know what's the next big service / maintence after the 30k one please?? or know where I can find out this information?? I've checked our owners manual ... if it says in there, then I probably must have missed it somehow :(

thanx again :)

amy ^_~
 

·
El Mucho Post Whoro
Joined
·
12,140 Posts
The clicking sound is due to the relay on the wire from the brake pedal/brake light circuit that triggers a solenoid in the transmission gear selector that locks/unlocks as ZEXCougar said. It's pretty normal for this to happen and I don't think you can really do much to remedy it. As far as the rest, it's an electrical problem (most likely). Get it checked!
 

·
Premium Member
Joined
·
1,754 Posts
zapphyre, have you had this problem fixed yet? I had the same exact thing happen to me last night. As far as the clicking noise goes, IT IS NOT NORMAL. There usually is a clicking noise on autos when you switch from park to a gear and after you let off the brake in park, but this is ridiculous, it clicks everytime the brake is touched while driving. This is definitely not the normal clicking noise.

From what I can tell, this is the only blown fuse in the car.
 
Z

·
Guest
Joined
·
0 Posts
Discussion Starter #6
Hi Zman,

Nope, haven't got it fix yet, needa call up dealers and schedule the service ... it's time for my 45k/50k service anywayz =|

I tried replacing the fuse too, but it blow right away when I press the power-lock button... so I guess mine is something else that's shorted ... i guess you're luckie =)

btw, thanx everybody for their input!! I'll try to get it fix asap ^__^

amy ^_~
 

·
Registered
Joined
·
92 Posts
my ATX just started doing the clicking anytime the brakes are touched and it gets annoying sometimes but dont really hear anything if I have the radio on so i have toned it out but as far as fixing it goes its not causing a problem with anything I havent checked the fuses but will to see it has anything to do with it but havent blown any fuses yet so if u do take it to get looked at i would take care of the fact you are blowing fuses then worry about the clicking if it isnt causing a prob when shifting from park to drive/reverse
 
G

·
Guest
Joined
·
0 Posts
Discussion Starter #8
Were you able to find out what the problem was that caused your locks and alarm to go nuts? My 2000 w/ATX started doing the same thing and I'm wondering if it's a fix I can do without taking it to the dealer.

Thanks!
 
1 - 8 of 8 Posts
Top