New Cougar Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello, I recently bought a 01 Mercury Cougar the other day and it's fantastic, besides some wiring issues. Currently the headlights (low beam and high), dash lights, and taillights do not work. All fuses have been triple checked and are all good with continuity. Lights work when relay is bypassed, just no power from the trigger wire, and no obvious harness damage going to switch. Switch itself is good, contacts have been cleaned as well. No power to any fuses related to headlight circuit at all, underhood and in the interior. Before I start ripping apart the whole wiring harness I was wondering if there was anything else I could check. Don't know if it's related but it has the original radio in it but does not work.
 

·
Premium Member
Joined
·
4,433 Posts
Your post seems to indicate you've checked most everything but the wiring. Check the points in yellow:
Rectangle Slope Font Line Parallel
 

Attachments

·
Registered
Joined
·
363 Posts
I had a draining problem on my 2000 due to the radio being bad. But to your question it dose sound like you have a bad wire somewhere. If your headlights don’t work pull the panel where the switch is located. I had a wire burn on me a few years ago. I ended up splicing a good section back in. Also do you know of the previous owner tampering with any of the dash wiring. The reason I ask is sometimes previous owners add something like an aftermarket alarm or radio and this sometimes messes with things like the cluster. If so I have some wiring pigtails and a complete dash wiring for the 01-02 cougar. And can help you if you have to tear the dash out. Thanks


Sent from my iPhone using Tapatalk
 
1 - 3 of 3 Posts
Top