New Cougar Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
832 Posts
Discussion Starter · #1 ·
Double posting here and FI forums:

Well my StreetFlight chip finally came in and had a working program. Turns out they burned my first two chips with a binary ka-something when it should have been a kb-something(or something like that anyway).

Plugged the chip in in the middle position and the car ran. Swapped out the stock injectors and MAF for the 42lb/hr and 70mm and the car ran with no deto. Tried the other two positions on the chip and it did what it was supposed to. Took the car out the driveway, punched it and there was barely any blips on the knock alert.

Only gave the car a quick up and down the highway for right now. I'll do a more thorough drive tomorrow and I'll check the plugs daily again for a few days.

Actually, it's probably not 200whp since I"m only running 8psi right now, but it's probably at least 190whp and 200tq. Now I just gotta go back to StreetFlight in December to fine tune and set the cam gears and hopefully...I'm done.
 
G

·
wow, good job man. all your hard work is really showing something now with the hp gains. keep up the good job! :thumbsup:
 

·
Registered
Joined
·
597 Posts
Hey Seawulf,

Nice to see you've got that boosted baby running again!..........:banana: I just picked up my turbo manifold from the machine shop this afternoon. I was having some porting work done on it. I pretty much have all of my components, and now it's just a matter of finding the time to hang up my ***** and do the install. Looks like I'll be joining you in the boosted club soon............:biggrin:
 

·
Registered
Joined
·
719 Posts
good work just dont blow it up this time
 

·
Registered
Joined
·
832 Posts
Discussion Starter · #7 ·
First long drive update:

Well the car hasn't blown up yet....again.:flushed:

Finally got a chance to go to Austin today(60mi away) and get a feel for how the car feels on the Interstate. So far not too shabby.

Upped the boost to 10 psi. The car was originally tuned for 9 psi but that was on 91 octane and I got 93 here and I also asked them to pull another deg of timing in the midrange so I feel it's safer.

Forget traction in first and second gear, I think I'm getting clutch slip. This car doesn't wheel spin it wheel hops and in first and second I've seen the revs suddenly shoot up quick past 4000rpm if I floor with no hop it so I figure that's clutch slip. Only does it in first and second at WOT, in 3rd and above no slip.

On the highway the car feels pretty good. It feels more stable past 90mph for some reason. The MSD Knock Alert is also not going off every few seconds. The chip supposedly get rids of the speed limiter and I was able to get it up to 120mph, couldn't go faster cause of weather and traffic, so I guess that works. Would like to see what 140 feels like just once.

Hooked up the OBD II scanner to see what the timing looked like and it looks like I have a max advance of 15 deg at cruise. Where at stock it's up to 30 at cruise. At WOT I've seen the timing go as low as 7. I may have to have the idle timing upped cause it's taking to long for the EGTs to come down. Fuel economy isn't too compromised. At 70-80 i'm able to get between 25-28mpg and at 80+ though I get around 20mpg. EGTs at cruise are around 1300 and at WOT the most i've seen so far are 1500.

Like I said the main difference is the car will accel without the knock alert beeping and at high highway speeds the car feels more stable for some reason. Maybe that's just psychological but before the car felt like it was always at the edge above 80mph now it feels sturdy above 80. Even when I took it up to 120 the car felt like it could still go higher if not for traffic.

Overall though it doesn't feel more powerful than before except in first and second gear. It feels better. Can't wait to head back to StreetFlight in Dec to tune the cam gears and fine tune the AF and see what kind of numbers I get then.
 

·
Banned
Joined
·
4,854 Posts
i understand ur a newb. but...START A NEW THREAD!!!!!!!!:slap:
 

·
Registered
Joined
·
832 Posts
Discussion Starter · #10 ·
Easy buff, you ain't been here much longer.

I'll go ahead and answer as best I can. Any fuel injector for a Focus will work. I got mine from McNews Automotive but I don't know if i'll ever shop there again, they took forever for my last order. A Focus TB would work but you have to modify it a bit, as it's not a direct bolt on I believe but other than that I don't know for sure on those.
 

·
Registered
Joined
·
832 Posts
Discussion Starter · #13 ·
Like I said, I don't know exactly.

Check the contour forums, they have more info on that stuff. www.contour.org
 
1 - 14 of 14 Posts
Top