New Cougar Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
91 Posts
Discussion Starter · #1 ·
I just had my car repaired for having a broken hego sensor and now the engine stops suddenly.

say I'm approaching a red light, I switch to neutral, go a few meters, then the engine stops suddenly.It also stops while i'm driving in first, second, third gear, etc. No discrimination whatsoever. Coming back from the garage where they replaced the hego sensor, a 10km drive, the engine stopped 7 or 8 times! I just shifted to a lower gear and gave it some gas, restarting it this way without using hte starter. Every snigle time it restarted perfectly, without hesitations!

So now the question..why is it stopping ?? What could be causing that ??
 

·
Registered
Joined
·
91 Posts
Discussion Starter · #3 ·
well, I was either in neutral or with the clutch pressed..so low RPM's shouldn't be affecting this.

my tank is more than 1/2 full so why would the fuel pump be doing this ? The car is extremely fast when I gun it, no hesitations, etc.
 

·
Registered
Joined
·
36 Posts
yeh mine is doin that to i have a automatic and it just dies on me for no reason. I had the value covers resealed cause oil was leakin in were the spark plugs were cause it to putt like i was low on gas . I got that fixed and know it will just die on me for no reason . It will start up just fine .My car dosnt putt anymore and runs fine .It just keeps dyin . Mabey its my distrubtor cap or alternator isnt chargin right . I know its not the battery cause its only a few months old. I dont know why iot keeps doin it tho
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top