New Cougar Forum banner
1 - 4 of 4 Posts
G

·
Discussion Starter · #1 ·
I got my yodude put on the other day and now my emission system light stays on. This isn't normal right. I'm taking my car to the dealer to get some stuff looked at and if they drive my car and see that light, they'll probabley ***** about my exhaust. Anyone have this happen?
 

·
Registered
Joined
·
4,342 Posts
What is an "emissions light"? There's a generic "Check Engine Light" (which is what I think you're getting), but that wouldn't be caused by an exhaust system. If you messed with the cats or O2 sensors, that would trigger a CEL- I'd take it in to the dealer if it's still under warranty, and don't even let them TRY to tell you it's the exhaust. Better yet, hook an AutoTap to it (if available) and see what the code is. That way you'll be forewarned when you take it in (or you can use the AutoTap to clear the CEL).

Hope this helps,
 
G

·
Discussion Starter · #3 ·
Thanks i'll do that. I only said "emissions system light" because I looked up the symbol in my manual and that's what it said.
 

·
Registered
Joined
·
728 Posts
it might coincidence that it came on when your put your exhaust on....you have the SCA CAI and so do i and i get CE lights before but i figured it out, it was the IAT sensor it wasnt in all the way or it kinda got loose from where it plugs to the car...might wanna unplug and plug the sensor then reset your ECU...or kind of face the sensor in a different direction
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top