New Cougar Forum banner
1 - 12 of 12 Posts

·
Premium Member
Joined
·
1,538 Posts
Discussion Starter · #1 ·
I was driving my cougar around town visiting my friends on my only day off. I had been driving for about an hour off & on. When I was on the highway with a.c. on going around 70mph my car started stuttering/jerking lightly at first then about 1/2mile later all of a sudden I just start losing power from the engine completely & started jerking harder with the MPH gauge just dropping to a complete stop where the car was barely idling @ 500rpm's. I just rev a few times & it takes off normal till around 30+mph & wants to die again. WTF is going on? I took it to the family shop & no codes come up for anything being wrong.
I got it towed there yesterday & called today & he said nothing was wrong when he drove it around. Then I go pick it up & 12 miles down the road it does the same sh!t like before. Has anyone got a clue what would cause this?
My car: 2001 I4 Zetec MTX
I have a aftermarket Intake, Exhaust, new wires/Plugs/& Ignition Coil.
Could it be my Timing chain or maybe my O2 sensors?:banghead::crazy::cry:
 

·
Registered
Joined
·
8,235 Posts
your loosing all power.... simply put doesnt matter what engine you have. Your alt isnt charging or wasnt for a bit there, im a bit suprised you didnt completely die. But anyway the 4 times ive had my alt completely die on the road thats how it went. Stereo cuts out... fans cut out... loose all gauges.... then DEAD.
 

·
Registered
Joined
·
3,206 Posts
Just so you know you have a timing BELT not a chain and needs to be replaced at a certain mile point which i don't since i drive a V6. Just thought i would throw that out there... :thumbsup:
 

·
Premium Member
Joined
·
1,538 Posts
Discussion Starter · #5 ·
Well I got it to the shop finally & they finally got to get the cougar to mess up on the 2nd test drive & comes to find out the F*cking Fuel Pump was going out. Theres a nice $445 for towing, labor. & parts. Now I have another problem I drove it back to my house 40 miles away & come to find out I have a gas leak because I had 1/2 tank of gas when leaving the shop & my light just came on when coming down my drive way. Sh!t this pisses me off.
 

·
Registered
Joined
·
197 Posts
Originally posted by: Josh125XR
Well I got it to the shop finally & they finally got to get the cougar to mess up on the 2nd test drive & comes to find out the F*cking Fuel Pump was going out. Theres a nice $445 for towing, labor. & parts. Now I have another problem I drove it back to my house 40 miles away & come to find out I have a gas leak because I had 1/2 tank of gas when leaving the shop & my light just came on when coming down my drive way. Sh!t this pisses me off.
Good ol' cougar =]
 

·
Registered
Joined
·
324 Posts
check the fuel rail....something is not right here and it's not just the cougars fault. check the tank right where the inlet tube (where you put your fuel in) and the tank meet i just replaced my friends for the same problem, then check the lines underneath the car and finally check the fuel rail. How did they find out it was your pump, fuel system pressure test?, removed the pump?
 

·
Premium Member
Joined
·
1,935 Posts
one of the 2 times i had my fuel pump replaced. the dealership broke the fuel filler pipe where it meets the fuel tank. that might be what happened here.

before anyone complains: i know 99Elimin8r just mentioned this possibility. i am just mentioning that it has happened to me as well.
 

·
Registered
Joined
·
124 Posts
u can test the fuel pump easily by unpluging the fuel filter and trying to turn on the car, put a container underneath the filter cuz will drop some gas (if its' working). this is only a fast test cuz it wont check pressure.

your fuel pumps are gonna get busted alotta, cuz is the 1st thing that fails after an alternator problem, you force it to give more gas even when has low AC power...
 

·
Premium Member
Joined
·
1,538 Posts
Discussion Starter · #10 ·
Well yesterday I got the shop to pick up the car & check it out with no charge cause there my relatives so they'll check it out for me. Also when they drove it up on to the tow truck a nice stream of gasoline came down the lift so they now its leaking for sure now. It sucks not driving the cougar around cause I have to drive the blazer till its out of the shop but its ok. I've been driving the SRT-4 around the last few days & I'm not complaining about it =D.
 

·
Registered
Joined
·
2,281 Posts
Originally posted by: sosaudio1
Could also be fuel cut-off switch...
Fuel cutoff switches do not turn on and off by themselves. This is an intermettitent problem here. Disregard sosauio's advice.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top