New Cougar Forum banner
1 - 13 of 13 Posts
G

·
Discussion Starter · #1 ·
SHe died on me three times today while driving....thankfully all while going straight and only one going over 30mph. Im confused on the problem any suggestions???
 

·
Registered
Joined
·
5,817 Posts
A less vauge description would be helpful. Exactly what happened?
 

·
Registered
Joined
·
674 Posts
well dying is because of something not getting what it needs.....best thing to check is your fuel pump, fuel filter, injector o-rings......I'm forgetting more because I'm on no sleep right now.
 
G

·
Discussion Starter · #4 ·
While crusing my stereo turned off and i looked at my gauges and the rpms read 0000 and i had no steering. The car simply died and shut off. THankfully i have MTX so all i had to do was start it up. The other two times i was stopped with the clutch in and it died. I thought at first it stalled but the car didnt jerk foward like it would if i stalled normally. IT was about 19 degrees out today as well.
Thank you for any input
 

·
Registered
Joined
·
674 Posts
um, fuel pump usually goes with bucking....but not always. Fuel injectors/o-rings you would know, large fuel smell, some bucking, some stalling, LOTS of gas spewing from below your intake manifold.

Could it be possible that there is moisture in your fuel filter or line somewhere that is freezing and blocking it? Tis possible to stall from lack of air/spark, but I have not had that problem.
 
G

·
Discussion Starter · #7 ·
As in bucking you mean like crap driving and it feels all rocking when i accelerate lightly. When i barely give it gas it "bucks" but during hard accelration its fine.
 

·
Registered
Joined
·
674 Posts
yea, except when I lost/was loosing my fuel pressure from injectors when trying to accel hard I went no where, an extreme boggle......but light accel did buck. Sounds like it could be your pump, or you could have a leak, possibly somewhere other than your injectors.
 

·
Registered
Joined
·
271 Posts
Sounds like fuel pump -- I've had mine replaced TWICE and it's started again (so far it hasn't stalled on me this time) - have an appt Weds to get it checked - atleast Ford will pay for this one, since it's been less than 10,000 mi since they put in the last one.

Chuck
 

·
Registered
Joined
·
4,973 Posts
Originally posted by: 2K1FrBlueC2
Sounds like fuel pump -- I've had mine replaced TWICE and it's started again (so far it hasn't stalled on me this time) - have an appt Weds to get it checked - atleast Ford will pay for this one, since it's been less than 10,000 mi since they put in the last one.

Chuck
and you're going to keep replacing it until you get a fuel pump that is NOT made by Ford.

Mike
 
1 - 13 of 13 Posts
Top