New Cougar Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
2,122 Posts
Discussion Starter #1
CRISPY or anyone else...how long do i have to wait after painting before applying the clearcoat?
it would seem last time i didnt wait long enough and the clearcoat kinda blended right into the paint kinda melted it i guess....i bought the right stuff this time though..
 

·
Registered
Joined
·
4,959 Posts
If it's a question of how many hours to let elapse, just be on the safe side and paint one day and clearcoat the next. And none of this paint at 11pm and clearcoat at 1am BS. :biggrin:
 

·
Registered
Joined
·
2,122 Posts
Discussion Starter #4
hehe i painted at 3:00 today...i guess i have to wait until tomorrow..

**ANOTHER QUESTION**i used that metal cast ground coat..it is pretty shinny but has slight orange peel look should i wet sand before clearcoating??
 

·
Registered
Joined
·
491 Posts
you can't wetsand mettalic paints... I think maybe you didn't clean it enough or sand it down properly when you were prepping it.

Maybe you should start over? and sand it down like a *****!
 

·
Registered
Joined
·
2,122 Posts
Discussion Starter #6
i talked to crispy she said i just sparyed a little to eagerly...put the coats on slightly too thick...it isnt reall yhtat noticable though...i think i am going to clear over it and buff it up...if it still looks wierd then i will start over...there isnt much light hitting it anyway where it will be in the car so i doubt you will even notice the slight orange peel look...thanx for the input though guys...i'll post pics later today..
 

·
Registered
Joined
·
2,122 Posts
Discussion Starter #7
pics are posted in pics/videos..heres a lazylink
 

·
Registered
Joined
·
2,122 Posts
Discussion Starter #8
well for sh*t sake...i waited for a day and a bit before applying the clearcoat and what do you know the friggin stuff ate the paint right off the piece now i am back to square one and have no idea what happened...any ideas people...this is a little disheartening..it was looking so good too..maybe not enough primer??hmmm try again i guess..
 

·
Registered
Joined
·
1,194 Posts
was the clear the same brand? sometimes different brand of spray paint react with eachother. Follow the directions on the can and it should work out.. usually :)

The last time i painted, i just waited for about 5 hours for the color coat to tack then sprayed one very very thing layer of clear on.. then let that tack. Then i repeated that like 5 or 6 times. Dont worry about any wetsanding until the clear is dry. Also make sure the primer is the same brand too.. Use thin coats and it should work you just need to be patient and let it tack up between coats. I learned that the hard way :)

I would have let the color coat dry longer but bugs kept on laning on it heh
 

·
Buyer Beware
Joined
·
6,575 Posts
What are you painting?:shrug:
 

·
Registered
Joined
·
536 Posts
I agree with slomoe, if your clearcoat is reacting with your base coat you are using products that are not compatible. Everything (primer, base/colorcoat, and clearcoat) must be the same type of paint.

I ran into the same problem back when I painted my dash. I bought OEM colorcoat and clearcoat from a body shop supply store but used Krylon primer from WalMart. Needless to say I painted that dash 3 times before I figured out what the problem was.
 
1 - 11 of 11 Posts
Top