New Cougar Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
627 Posts
Discussion Starter #1
I have all of the parts listed below on my car. And eversince i installed all of it, my check CE light has been on. Why and how can i fix it?
 

·
Registered
Joined
·
6,301 Posts
You are getting the CEL because.....










wasn't that helpful!:biggrin:


If you are looking for help we need a little more info, and might I suggest helping yourself buy going to autozone and have them scan it to see what codes its putting out
 

·
Registered
Joined
·
4,189 Posts
SVT TB is a 60mm TB, some places mis advertise ot as a 65mm...


Most likely you are getting issues from the MAF and injectors. They are probably having calibration issues. This is the reason, sticking to the stock MAF and stock 17;bers is the best way to go.

However, your CEL could be from many other things. It could be anyt other sensor in the car. You need an OBD2 scanner tool or as advised before, go to a local autozone, or place that'll read the code for little to no charge.
 

·
Registered
Joined
·
47 Posts
I got these error codes: EEC-V error codes, P1100, P0172 & P0175, P1100 Mass Air Flow Sensor Intermittent, P0172 System Too Rich - Bank No. 1 & P0175 System Too Rich - Bank No. 2.
My solution was A MAF optimizer. The problem for me was a too rich mixture for idle. I'm still playing with the manual settings on the MAF optimizer.
My Cougar was stalling/quitting when the engine went from high revs to an idle, like at a stop, with the new MAF, TB, SVT upper and lower Manifols and the 19 LBs injectors. The mixture was too rich for idle.
When you increase the mixture too rich for driving, you have to decrease the mixture (rich) for idle.
The 75mm MAF just was not calibrated correctly for my setup.
 

·
Registered
Joined
·
4,189 Posts
Like I always tell people...bumping to 19lb injectors woth the simple bolt ons is just a waste. If you took the car to be dyno tuned afterwards, you'd be fine...

I do just fine on my 17's
 
1 - 5 of 5 Posts
Top