New Cougar Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
305 Posts
Discussion Starter · #1 ·
So I tried replacing my license plate lights with an led bulb. Got the first one in and it worked, put the second one in turn on the lights and now both aren't working. Also my light for the headlight switch and glove box are also out????? What happened here, if it is a fuse which one is it? Thanks
 

·
Registered
Joined
·
2,319 Posts
When you start your car, do your gauges "sweep" from 0-...? If they do, then it's definately a blown fuse.

If they don't sweep, it's still probably a blown fuse. Next time, unhook your battery before messing around with your car - it'll save you some money in fuses, and it's just good practice.

I am not sure *which* fuse it is - look in your manual, or just pull each fuse out and look to see if it is blown, it onlys takes a couple minutes to look at every fuse.
 

·
Registered
Joined
·
305 Posts
Discussion Starter · #3 ·
The gauges dont't "sweep" at all, everything works fine except for the headlight control lights, glove box, and license plate lights. Which fuse box would I look for the blown fuse, interior or exterior??
 

·
Registered
Joined
·
3,206 Posts
Fuse #31... 7.5 amps which makes it a brown one. Its that fuse and $100 says its blown! Go change it.

Its the fuse panel under the dash by the drivers feet.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top