New Cougar Forum banner
1 - 20 of 51 Posts

·
Registered
Joined
·
778 Posts
Discussion Starter · #1 ·
Hello

My car is not starting, not even clicking - nothing was wrong with the battery before install.

I also replaced spark plugs.

Tried to start the car but nothing. This is my daily driver and am stranded. Any body please know what could be the problem with the car not starting? Im pretty sure all plugs are plugged back in.
 

·
Registered
Joined
·
2,307 Posts
need to start out by checkign the battery and connections. make sure tha battery has a full charge and that the connections are clean and good and tight. also check for blow fuses.

also what is the rest of the car doing when you go to start it? dash lights, pats light, etc?
 

·
Registered
Joined
·
778 Posts
Discussion Starter · #3 ·
Everything else is working. I just don't here a click or anything that lets me know that it is the battery. The enterior lights work.

At first I even tried to jump start the car cause I though it was the battery. But still no clicking or anything.

I completey forgot to look at the fuses. I will do that when I get back from work. Off head anybody know what fuse to look at?
 

·
Registered
Joined
·
778 Posts
Discussion Starter · #5 ·
I PRAY it not starter. I just got the darn thing replaced a few months ago.

However, if it is the starter, wouldn't it at least click?

Anybody know the starter fuse? Inside or Outside compartment?
 

·
Registered
Joined
·
778 Posts
Discussion Starter · #6 ·
Just looked at manual.

The fuse items dealing with the starter are:
- Fuse 40 - 20 amps - Blue - Ignition, starting, headlamp switch
- Relay R7 - green - Starter

I am assuming the number 40 is the type of fuse that you can see if it is bad or not. These can be purchased at auto store correct? (20amps) (although the manual says that this fuse should be replaced by dealer or technician. Why?)

Now if the relay is the problem, how will I know? And how can I replace? Is it a dealer part or can it be purchased at auto store.

I ask b/c im at work and when I get off work to deal with the car the dealerships will be closed and I would hate to have to wait another day again to ask for parts.
 

·
So its begun.....
Joined
·
16,840 Posts
In your upgrading did you happen to remove the coil pack? If so did you make sure that grounding strap was reconnected? There were a couple instances of cars not starting because of that.
 

·
Registered
Joined
·
778 Posts
Discussion Starter · #9 ·
In your upgrading did you happen to remove the coil pack? If so did you make sure that grounding strap was reconnected? There were a couple instances of cars not starting because of that.
I didn't remove the coil pack. I'm assuming that is the part that all the spark plugs plug into. I didn't remove anything from there.

Either way do you have pics of this "grounding strap"?
 

·
Registered
Joined
·
778 Posts
Discussion Starter · #10 ·
You could try to bump start it.
Bump start? Do you mean jump start? If so, i tried that yesterday. Didn't even click.

I checked all the fuses. Non are blown. All the lights work, parking lights fog lights. Even alarm, like that makes any difference. The fuel primer comes on and everything. But when I turn the ignition, nothing. The dash lights go out like they suppose to as though about to start, but nothing.

PLEASE help. I have no car to use for tomorrow. I plugged back in all what the instructions say to unplug. about 4-5 electrical plugs correct?
 

·
Administrator
Joined
·
15,565 Posts
Have you tried using jumper cables or a booster pack? Make sure the cables are pushed as far down on the terminals as possible and that they are tight.
 

·
Registered
Joined
·
778 Posts
Discussion Starter · #12 ·
Alright - for some reason I don't, was just pulling fuses and putting the back in, the ignition now works.

However, now the car is not turning. I can here the fly wheel turning when I hold the ignition but no turning of engine.

Diagnosis?
 

·
Registered
Joined
·
778 Posts
Discussion Starter · #14 ·
Yeah sort of. I kept starting and starting it would just keep turning and start coughing and then stop and then churn slightly but then it started coughing a little more and then........VROOOOOM. *tear*:cry: it was one of the most beautiful sounds I ever heard. I was so proud of my baby. She pulled through.

........next week it will be new headers :eek:.......pray for her.....and me.......

Thanks for help folks!!! :wiggle:
 

·
Registered
Joined
·
778 Posts
Discussion Starter · #15 ·
I went for a spirited drive but noticed that the car wasnt running smoothly during spirited acceleration. During slow acceleration the car was fine.

Is this just because the car needs time to "re-learn" settings? Or is there something I can do to fix this?
 

·
Registered
Joined
·
281 Posts
Possibly, try disconnecting the battery for 30 minutes to reset the ECU and then take it for a good drive.
I had a smimilar problem to your after changing my crank pulley to a UDP, and when i started it for the first time it just squeeled and didnt fire at all. My ass fell out and i though 'oh no iv shafted my car:('. But i plucked up the courage to start her again and it was the same, just slightly less squeeling. So i kept on trying and she fired after about 5 attempts :rofl:

Its a horrible feeling when you do work on your car (when not hugely experienced) and the thing wont start.
 

·
Registered
Joined
·
778 Posts
Discussion Starter · #17 ·
Possibly, try disconnecting the battery for 30 minutes to reset the ECU
But the battery was disconnected the whole time I was installing Svt upgrade.


I had a smimilar problem to your after changing my crank pulley to a UDP, and when i started it for the first time it just squeeled and didnt fire at all. My ass fell out and i though 'oh no iv shafted my car:('. But i plucked up the courage to start her again and it was the same, just slightly less squeeling. So i kept on trying and she fired after about 5 attempts :rofl:

Its a horrible feeling when you do work on your car (when not hugely experienced) and the thing wont start.
I feel ya on that one. Especially when you take care to plug everything back where you found it. makes you second guess your self soo much. I was like "dang i know I put and plugged everything back, infact I know I did a heck of a job" lol

Yeah so on to the not smooth in spirited accelerations. What is the deal?
 

·
Registered
Joined
·
778 Posts
Discussion Starter · #20 ·
What does it mean when the CEL starts to blink? The car makes gurgly sounds when accelerating hard. And after pushing it to try to figurer out Y it does that, the CEL light starts to blink and then goes stops after a few blinks.
 
1 - 20 of 51 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top