New Cougar Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
2,944 Posts
Discussion Starter · #1 ·
I am currently grounding my amps on the latches for the backseat. Whenever I put down the back seats, my amps slowly fade and turn off. I am curious, where does the majority ground their caps and amps?
 

·
Registered
Joined
·
5,952 Posts
i grounded mine along with the wires grounded for the tail lights. its worked for me!
 

·
Registered
Joined
·
1,363 Posts
the best thing to do is scratch some paint from the trunk floor to ensure metal is showing
get like a ring terminal for the end of the wire and screw it down
make sure that the terminal is touching as much metal as possible
 
G

·
i pulled off the cover in the very back of the trunk where the hatch comes down and locks. down on the bottom there is a thread hole where nothing is so i sctrached the paint and put a bolt in there with the same threading.
 

·
Registered
Joined
·
2,122 Posts
i too sanded down an area under the tailight ground on the drivers side...no problems yet...
 

·
Registered
Joined
·
248 Posts
Originally posted by: JAMallott
i grounded mine along with the wires grounded for the tail lights. its worked for me!
Same here. Worked great!
 

·
Registered
Joined
·
388 Posts
this is what I did for short term, I was looking at getting a distribution block to do all my gnd's, kinda like a power block.
 

·
Registered
Joined
·
24 Posts
ok here's what you do... if you have a dremel with a wirebrush attachment or any sanding attachment it'l be mad easy, take the bolt out of the back seat that you're using for ground and just use the dremel or sand paper to sand off the underside of the head of the bolt... and at the bottom of the bolt after the threads stop... i did that with mine and never had a problem again when putting the back seats down.... i'll take a pic if you want being as i had to sell my system so i can still make the payments on the car lol... no job= no more mods lol and all i have left are my 2 voodoo 1 farad caps... looks kinda silly now lol 0ga wire and 2 caps no subs or amp lol... oh well pm me if you need help again with system stuff
-jay
 
1 - 11 of 11 Posts
Top