New Cougar Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
177 Posts
Discussion Starter · #1 ·
my battery has died three times in the last 2 weeks. i got a jump and it started up instantly every time.
i also started my car and unpluged the negitive battery cable and although the lights dimmed a little the car stayed on so that rules out my alternator right??? so i guess my question is do i need a new battery or alternator?
what else could it be? my battery light was not flashing and my car has 92,000 with no alternator problems ever.
 

·
Registered
Joined
·
3,206 Posts
You did the old way alternator test! LOL Get a multimeter and see how much the alternator is putting out. Your battery could be bad or the alternator and battery are bad. Need to test more.
 

·
Administrator
1999 3.0 SilFro
Joined
·
25,008 Posts
Sounds to me like your battery is crap.
 

·
Registered
Joined
·
557 Posts
Either your battery isn't holding it's charge anymore or your alt isn't giving enough amperage,your need a carbon pile to check these
right.I've seen a lot of alternators pushing good voltage but far from their max amp output so a multimeter will only give you an idea
if your alt is good or not.It seems the stock batteries in contours and cougar aren't very good.My tour is on it's 4th batt in 10 yrs and
did the same thing every time,it would just short out with no warnings after 3 yrs no matter what brand I used.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top