New Cougar Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
81 Posts
Discussion Starter · #1 ·
I have a 2001 ATX cougar with Injen Intake ---> Gutted Prescats ---> DMD ---> Pro Flow 75mm MAF ---> 19Lb/H Injectors ---> Custom Single Exhaust ---> Remote Optimizer and i get very bad gas mileage is there a reason for that??? Is it the injectors??? I change out the oil last time but didn't replace the filter would that be the reason??? Thanks ^.^
 

·
Registered
Joined
·
2,539 Posts
find out. swap out the injectors and maf.

Many will tell you the Pro-Flo isnt necessary. There are a few members running 3.0's with more mods than you can count on 2 hands pushing plenty over 200 WHP still retaining the stock Maf.
 

·
Registered
Joined
·
2,620 Posts
Originally posted by: Kami
I have a 2001 ATX cougar with Injen Intake ---> Gutted Prescats ---> DMD ---> Pro Flow 75mm MAF ---> 19Lb/H Injectors ---> Custom Single Exhaust ---> Remote Optimizer and i get very bad gas mileage is there a reason for that??? Is it the injectors??? I change out the oil last time but didn't replace the filter would that be the reason??? Thanks ^.^
Since I sell performance, long milage oil; please, never change the oil without changing the filter.. You are just leaving the source of crud in the oils only path thru the engine.
So how bad is your gas mileage??? It maybe a problem with your car or the way you drive.. How do you drive.. city.. freeway.. cold weather and you like to warm-up the car??
I have many of the same mods as you (No optimizer or DMD) and get 33 at freeway and 15 full-out on the road courses. That's going between 0 (on the grid) and 140 mph on the (long) straights...
 

·
Registered
Joined
·
47 Posts
Have you tried disconnecting the battery overnight, resetting the computer? I'm getting 28-29 MPH with the stock wheels and my manual MAF optimizer with the 19 LB injectors and SVT LIM, UIM, and listed MODs. I think I need to try a richer mixture on the MAF optimizer.
Maybe it's your MAF Optimizer, but I would think the car would be running like SH#t.
 

·
Registered
Joined
·
145 Posts
Mrforge.. isn't the problem of oil going bad the actually additives in the oil are running out?
 

·
Registered
Joined
·
81 Posts
Discussion Starter · #6 ·
thank you all ^.^ i found out the problem it's the optimizer I tune it way too lean and now i've change it and everything is running smooth and the Gas mileage are back to normal.
 
1 - 7 of 7 Posts
Top