New Cougar Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1,166 Posts
Discussion Starter #1
Well, as was said in my last post about this - my car died last Saturday. I took it to the dealership and after having my car until Monday morning, they diagnosed it as the battery having a dead cell. I replaced it with a red top, and everything is fine - no light dimming. My question is this: My alternator is covered under the extended warranty that I bought for my car. This is the third battery replacement I have had to do this year! Obviously, there is something going on besides just a stream of bad luck with batteries. I am continually told by the dealership that my alternator tested fine. The last time my battery died, I was told by someone on here to have them test the alternator under load. When the dealership diagnosed my problem this time, I asked them to test it under load - and they said that they did and everything was fine. The only thing that I can think of that would cause this besides the alternator is my stereo system. My amp is an Alpine that puts out 100watts to the sub, and 50watts to each of the 4 indash speakers. I wouldn't think that this is enough to kill my battery. Any suggestions on how to get them to identify my alternator problem? Or if it actually isn't an alternator problem, why am I on my fourth battery this year?
 

·
Registered
Joined
·
5,817 Posts
Our alts fail for a few different reasons. Mine checked out perfect under every test, even thought it failed the next day. I tested it myself, and everything was fine.....so there is no sure fire way to be 100% your alt is going bad...unfortunatly.
 

·
Registered
Joined
·
137 Posts
My alt also tested fine on an avr but when the light dimming got worse and the battery light started kicking on I had it retested and sure enough the alt was going.
 
1 - 4 of 4 Posts
Top