New Cougar Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter · #1 ·
has anyone ever had problems with your car ( 99 cougar, v6 engine ) hesitating or studering when you accelerate? the check engine light is on and we cant figure out how to get it off.
 

·
Registered
Joined
·
3,206 Posts
Umm please tell me your joking about the check engine light right... Well if you aren't, find a local Autozone. They will "pull" your codes for free and tell u them. Thats a start!
 

·
Administrator
1999 3.0 SilFro
Joined
·
24,934 Posts
Yeah, you should post this in the PROBLEMS forum.

I had that problem, and it turned out to be plugs and wires. If yours are old, replace them. All at once. If they are new, make sure all wires go to their proper posts on the coil pack.
 

·
Registered
Joined
·
39 Posts
Discussion Starter · #4 ·
Originally posted by: mond12345
Umm please tell me your joking about the check engine light right... Well if you aren't, find a local Autozone. They will "pull" your codes for free and tell u them. Thats a start!
i did get it checked and all it said was that it is running lean. i've got it checked at 3 different places, so obveously that wasnt a good start. :tongue:
 

·
is a pop sensation
Joined
·
13,675 Posts
Get the actual code number from them instead of just their diagnosis. The codes will help narrow the possibilities.
 

·
Registered
Joined
·
3,206 Posts
Originally posted by: Kdubbz30
Originally posted by: mond12345
Umm please tell me your joking about the check engine light right... Well if you aren't, find a local Autozone. They will "pull" your codes for free and tell u them. Thats a start!
i did get it checked and all it said was that it is running lean. i've got it checked at 3 different places, so obveously that wasnt a good start. :tongue:
Try to find out the code, P****, so that we can try to help more.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top