New Cougar Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
I made the mistake of buying an auto, and now at 67000 miles, im starting to experience probelms. When i am under heavy acceleration, or i am driving for an extended period of time, the transmission will slow down terribly. Sometimes it will pull and let off, and other times it will barely pull at all.the other day it took me almost 30 seconds to get to 60 mph. Something isnt right. I have the warranty, but like it says sometimes it will work fine sometimes it wont. Has anyone had any experience with this problem? if you have, any input would be greatly appreciated. Thanks
 

·
Registered
Joined
·
7,247 Posts
Are you sure its in the transmission? It sounds like you may be having an issue with the IMRC's, not the tranny. IMRC = Intake Manifold Runner Control. Its the little electric part that opens the second set of butterflies, giving you more power above 4400 rpm's. Sometimes this gets bad, and it won't work properly, killing your acceleration. I find it happens once I've been driving for a while and the heat builds up under the hood.

So it may not be your tranny at all. Check out the "How To's" section, and look at the "IMRC Fix" thread. Try that first and see if thats your problem.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #3 ·
Thanks almot man...appreciate it. ill check that out
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top