New Cougar Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4,342 Posts
Discussion Starter #1
12/3: Exhaust Finished!

Not too thrilled with the sound- There's a barking "rasp" when you gun it- Not happy.. Otherwise, it's a :thumbsup: job! <toot, toot>

Here goes with the pics:

The new S pipe @ the welders getting the reducer welded on:



The bead:



Now, back at home- The 3" piping forward of the muffler, showing flange for modularity, painted at the non-stainless parts & clamps with 1200* hi-temp silver:



The new part- 3" to 2.5" reducer, painted:



From the rear:



The new S-pipe, going to the rest of the system (painted clamps again):



At the Y:



And the tips:



Can't say I've noticed any difference in power, but it's been two weeks since I've driven the damn thing... Maybe the computer will set in over the next few days and realize that my baby can actually BREATHE now...

Next step: Resonators before the tips to get rid of some volume and hopefully the bark.
 

·
Registered
Joined
·
4,342 Posts
Discussion Starter #4
Is that before or after the S pipe separated from the Y? :ugh:

And hey! You didn't mention the acceleration! :slap:

Fixed it yesterday in the frigid, blowing wasteland that is Gainesville. Had to search all over Manassass to find a place with a 2.5-3" tailpipe expander. Finally got one, but had to go find a retaining nut for it since Auto Zone had lost the thing. Then I had to clean the threads on the expander in order to actually make it work... Then I had to heat the pipe with a torch until it glowed red, jammed the expander in it, and cranked it down until I couldn't move the wrench. Then I had to repeat the whole thing twice more before I could get the pipe on more than 3/4"...

Sound like a CF to anyone else but me? Damn used systems... Ya try to be a nice guy, and look what it gets you... :disgust:
 
1 - 4 of 4 Posts
Top